Fork me on GitHub

Sunday, June 23, 2013

Scaloid 2.1 is released

Today I released Scaloid version 2.1.

Improvements in this version is shown below:

  • Fixed a regression related to SArrayAdapter
  • Uses ClassTag instead of ClassManifest, which is deprecated from Scala 2.10
  • Improved APIdoc
  • Covers Android API more completely (added SWebView)

This version is not binary compatible with previous versions. Please clean rebuild your project to upgrade Scaloid to 2.1.

You can include this version of Scaloid into a maven project by:
<dependency>
    <groupId>org.scaloid</groupId>
    <artifactId>scaloid_2.10</artifactId>
    <version>2.1-8</version>
</dependency>
or a sbt project by:
libraryDependencies += "org.scaloid" %% "scaloid" % "2.1-8"

1 comment:

  1. I have updated the scaloid-examples to work with Scaloid 2.1-8. Note that a user may need to also clone and build the android plugin for SBT if the snapshot is not available from public repos.

    ReplyDelete